Product Notices

On this page:

Release Alerts

Release Alert for Itential Automation Gateway

This release alert refers to an exception situation in connection with Itential Automation Gateway (IAG). There is a conflict definition error in the pronghorn.json of app-ag_manager.

The root cause of the conflict is a schema mismatch between modules, roles, playbooks or scripts with same name across all instances of IAG connected to Itential Automation Platform (IAP).

The error looks like this:

Cannot find match for input: \"ERROR\" from model

Explanation of problem

  • If there are multiple IAGs connected to IAP, and the Ansible version of all IAGs are not same (i.e., IAG1 has Ansible v2.7.3 and IAG2 has Ansible v2.8.1), that mismatch creates a schema mismatch.
    • The conflict issue is caused when two different versions of a module are developed with different schema parameters (params).
    • For example, a module named iosxr_config in Ansible v2.7.3 has params x,y,z but the same module has params x,y,z,s in Ansible v2.8.1. With this example, there is now a conflict in schema for the given module.
  • Prior to release 2020.1.5, an error parameter was implemented in the pronghorn.json of app-ag_manager for that given module which restricted the customer from using the given task in IAP automations.
  • After 2020.1.5, Itential implemented a fix where customers can still use the task, but an error message is logged in the task description so customers can fix the IAG version that is causing the conflict.

How to handle this error after 2020.1.5

To fix the conflict:

  1. Make sure all IAGs connected to IAP have the same version of IAG and Ansible.
  2. Use the undiscoverall call to remove all discovered modules, roles, playbooks, etc.
  3. Once every instance of IAG and Ansible is on the same version, and after running the undiscoverall action, restart all Automation-Gateway adapters.
  4. Please allow a 5 second buffer to avoid race conditions.